Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2018-18311: Important: perl security update (CESA-2019:0109)

Back to Search

Centos Linux: CVE-2018-18311: Important: perl security update (CESA-2019:0109)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/29/2018
Created
03/19/2019
Added
01/25/2019
Modified
03/03/2021

Description

Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations.

Solution(s)

  • centos-upgrade-perl
  • centos-upgrade-perl-core
  • centos-upgrade-perl-cpan
  • centos-upgrade-perl-debuginfo
  • centos-upgrade-perl-devel
  • centos-upgrade-perl-extutils-cbuilder
  • centos-upgrade-perl-extutils-embed
  • centos-upgrade-perl-extutils-install
  • centos-upgrade-perl-io-zlib
  • centos-upgrade-perl-libs
  • centos-upgrade-perl-locale-maketext-simple
  • centos-upgrade-perl-macros
  • centos-upgrade-perl-module-corelist
  • centos-upgrade-perl-module-loaded
  • centos-upgrade-perl-object-accessor
  • centos-upgrade-perl-package-constants
  • centos-upgrade-perl-pod-escapes
  • centos-upgrade-perl-tests
  • centos-upgrade-perl-time-piece

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;