Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2021-22883: Important: nodejs:12 security update (Multiple Advisories)

Back to Search

Centos Linux: CVE-2021-22883: Important: nodejs:12 security update (Multiple Advisories)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:C)
Published
03/03/2021
Created
03/09/2021
Added
03/08/2021
Modified
03/12/2021

Description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Solution(s)

  • centos-upgrade-nodejs
  • centos-upgrade-nodejs-debuginfo
  • centos-upgrade-nodejs-debugsource
  • centos-upgrade-nodejs-devel
  • centos-upgrade-nodejs-docs
  • centos-upgrade-nodejs-full-i18n
  • centos-upgrade-nodejs-nodemon
  • centos-upgrade-nodejs-packaging
  • centos-upgrade-npm

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;