Rapid7 Vulnerability & Exploit Database

Debian: CVE-2020-29050: sphinxsearch -- security update

Back to Search

Debian: CVE-2020-29050: sphinxsearch -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
01/10/2022
Created
01/11/2022
Added
01/10/2022
Modified
01/17/2022

Description

SphinxSearch in Sphinx Technologies Sphinx through 3.1.1 allows directory traversal (in conjunction with CVE-2019-14511) because the mysql client can be used for CALL SNIPPETS and load_file operations on a full pathname (e.g., a file in the /etc directory). NOTE: this is unrelated to CMUSphinx.

Solution(s)

  • debian-upgrade-sphinxsearch

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;