Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2016-9594: cURL: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2016-9594: cURL: Multiple vulnerabilities

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
01/19/2017
Created
07/25/2018
Added
10/30/2017
Modified
05/29/2018

Description

curl before version 7.52.1 is vulnerable to an uninitialized random in libcurl's internal function that returns a good 32bit random value. Having a weak or virtually non-existent random value makes the operations that use it vulnerable.

Solution(s)

  • gentoo-linux-upgrade-net-misc-curl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;