Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2021-32761: Redis: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2021-32761: Redis: Multiple Vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:S/C:P/I:P/A:P)
Published
07/21/2021
Created
09/30/2022
Added
09/30/2022
Modified
09/30/2022

Description

Redis is an in-memory database that persists on disk. A vulnerability involving out-of-bounds read and integer overflow to buffer overflow exists starting with version 2.2 and prior to versions 5.0.13, 6.0.15, and 6.2.5. On 32-bit systems, Redis `*BIT*` command are vulnerable to integer overflow that can potentially be exploited to corrupt the heap, leak arbitrary heap contents or trigger remote code execution. The vulnerability involves changing the default `proto-max-bulk-len` configuration parameter to a very large value and constructing specially crafted commands bit commands. This problem only affects Redis on 32-bit platforms, or compiled as a 32-bit binary. Redis versions 5.0.`3m 6.0.15, and 6.2.5 contain patches for this issue. An additional workaround to mitigate the problem without patching the `redis-server` executable is to prevent users from modifying the `proto-max-bulk-len` configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.

Solution(s)

  • gentoo-linux-upgrade-dev-db-redis

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;