Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2018-10915: postgresql security update

Back to Search

Huawei EulerOS: CVE-2018-10915: postgresql security update

Severity
6
CVSS
(AV:N/AC:M/Au:S/C:P/I:P/A:P)
Published
08/09/2018
Created
03/19/2019
Added
09/27/2018
Modified
12/17/2018

Description

A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

Solution(s)

  • huawei-euleros-2_0_sp3-upgrade-postgresql
  • huawei-euleros-2_0_sp3-upgrade-postgresql-contrib
  • huawei-euleros-2_0_sp3-upgrade-postgresql-devel
  • huawei-euleros-2_0_sp3-upgrade-postgresql-docs
  • huawei-euleros-2_0_sp3-upgrade-postgresql-libs
  • huawei-euleros-2_0_sp3-upgrade-postgresql-plperl
  • huawei-euleros-2_0_sp3-upgrade-postgresql-plpython
  • huawei-euleros-2_0_sp3-upgrade-postgresql-pltcl
  • huawei-euleros-2_0_sp3-upgrade-postgresql-server
  • huawei-euleros-2_0_sp3-upgrade-postgresql-test

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;