Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2022-1292: openssl security update

Back to Search

Huawei EulerOS: CVE-2022-1292: openssl security update

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
05/03/2022
Created
07/16/2022
Added
07/11/2022
Modified
07/11/2022

Description

The c_rehash script does not properly sanitise shell metacharacters to prevent command injection. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2). Fixed in OpenSSL 1.1.1o (Affected 1.1.1-1.1.1n). Fixed in OpenSSL 1.0.2ze (Affected 1.0.2-1.0.2zd).

Solution(s)

  • huawei-euleros-2_0_sp9-upgrade-openssl
  • huawei-euleros-2_0_sp9-upgrade-openssl-libs
  • huawei-euleros-2_0_sp9-upgrade-openssl-perl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;