Rapid7 Vulnerability & Exploit Database

Moodle: Improper Authorization (CVE-2019-14828)

Back to Search

Moodle: Improper Authorization (CVE-2019-14828)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:P/A:N)
Published
03/19/2021
Created
03/31/2021
Added
03/30/2021
Modified
03/30/2021

Description

A vulnerability was found in Moodle affecting 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where users with the capability to create courses were assigned as a teacher in those courses, regardless of whether they had the capability to be automatically assigned that role.

Solution(s)

  • moodle-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;