Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2018-11358: Vulnerability in Wireshark

Back to Search

Oracle Solaris 11: CVE-2018-11358: Vulnerability in Wireshark

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
05/22/2018
Created
07/25/2018
Added
06/18/2018
Modified
01/19/2021

Description

In Wireshark 2.6.0, 2.4.0 to 2.4.6, and 2.2.0 to 2.2.14, the Q.931 dissector could crash. This was addressed in epan/dissectors/packet-q931.c by avoiding a use-after-free after a malformed packet prevented certain cleanup.

Solution(s)

  • oracle-solaris-11-3-upgrade-value-diagnostic-wireshark-2-6-1-0-175-3-33-0-5-0
  • oracle-solaris-11-3-upgrade-value-diagnostic-wireshark-tshark-2-6-1-0-175-3-33-0-5-0
  • oracle-solaris-11-3-upgrade-value-diagnostic-wireshark-wireshark-common-2-6-1-0-175-3-33-0-5-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;