Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2019-11291: Vulnerability in RabbitMQ

Back to Search

Oracle Solaris 11: CVE-2019-11291: Vulnerability in RabbitMQ

Severity
4
CVSS
(AV:N/AC:M/Au:S/C:N/I:P/A:N)
Published
11/22/2019
Created
01/20/2021
Added
01/19/2021
Modified
11/17/2021

Description

Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.

Solution(s)

  • oracle-solaris-11-4-upgrade-value-network-amqp-rabbitmq-3-8-3-11-4-24-0-1-75-1

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;