Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2021-3537: Moderate: libxml2 security update (RLSA-2021-2569)

Back to Search

Rocky Linux: CVE-2021-3537: Moderate: libxml2 security update (RLSA-2021-2569)

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
05/14/2021
Created
05/06/2022
Added
05/05/2022
Modified
05/05/2022

Description

A vulnerability found in libxml2 in versions before 2.9.11 shows that it did not propagate errors while parsing XML mixed content, causing a NULL dereference. If an untrusted XML document was parsed in recovery mode and post-validated, the flaw could be used to crash the application. The highest threat from this vulnerability is to system availability.

Solution(s)

  • rocky-upgrade-libxml2
  • rocky-upgrade-libxml2-debuginfo
  • rocky-upgrade-libxml2-debugsource
  • rocky-upgrade-libxml2-devel
  • rocky-upgrade-python3-libxml2
  • rocky-upgrade-python3-libxml2-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;