Rapid7 Vulnerability & Exploit Database

Vmware Spring: CVE-2022-22950: Spring Expression DoS Vulnerability

Back to Search

Vmware Spring: CVE-2022-22950: Spring Expression DoS Vulnerability

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
03/28/2022
Created
04/19/2022
Added
04/14/2022
Modified
04/18/2022

Description

n Spring Framework versions 5.3.0 - 5.3.16 and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

Solution(s)

  • upgrade-spring

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;