Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2021-3115: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2021-3115: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:N/AC:H/Au:N/C:P/I:P/A:P)
Published
01/13/2021
Created
01/28/2021
Added
01/27/2021
Modified
02/17/2021

Description

Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).

Solution(s)

  • suse-upgrade-go1-14
  • suse-upgrade-go1-14-doc
  • suse-upgrade-go1-14-race
  • suse-upgrade-go1-15
  • suse-upgrade-go1-15-doc
  • suse-upgrade-go1-15-race

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;