Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2018-1000301): curl vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2018-1000301): curl vulnerabilities

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
05/16/2018
Created
07/25/2018
Added
05/23/2018
Modified
03/02/2020

Description

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

Solution(s)

  • ubuntu-upgrade-curl
  • ubuntu-upgrade-libcurl3
  • ubuntu-upgrade-libcurl3-gnutls
  • ubuntu-upgrade-libcurl3-nss
  • ubuntu-upgrade-libcurl4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;