Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2021-23358): Underscore vulnerability

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2021-23358): Underscore vulnerability

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
03/29/2021
Created
04/16/2021
Added
04/15/2021
Modified
03/24/2022

Description

The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.

Solution(s)

  • ubuntu-upgrade-libjs-underscore
  • ubuntu-upgrade-node-underscore

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;