Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2021-39275: Moderate: httpd:2.4 security update (ALSA-2022-0891)

Back to Search

Alma Linux: CVE-2021-39275: Moderate: httpd:2.4 security update (ALSA-2022-0891)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
09/16/2021
Created
05/05/2022
Added
05/04/2022
Modified
05/20/2022

Description

ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.

Solution(s)

  • alma-upgrade-httpd
  • alma-upgrade-httpd-devel
  • alma-upgrade-httpd-filesystem
  • alma-upgrade-httpd-manual
  • alma-upgrade-httpd-tools
  • alma-upgrade-mod_ldap
  • alma-upgrade-mod_md
  • alma-upgrade-mod_proxy_html
  • alma-upgrade-mod_session
  • alma-upgrade-mod_ssl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;