Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2019-3832: libsndfile heap-based buffer over-read and incomplete fix

Back to Search

Alpine Linux: CVE-2019-3832: libsndfile heap-based buffer over-read and incomplete fix

Severity
2
CVSS
(AV:L/AC:M/Au:N/C:N/I:N/A:P)
Published
03/21/2019
Created
12/18/2019
Added
11/08/2019
Modified
12/04/2019

Description

It was discovered the fix for CVE-2018-19758 (libsndfile) was not complete and still allows a read beyond the limits of a buffer in wav_write_header() function in wav.c. A local attacker may use this flaw to make the application crash.

Solution(s)

  • alpine-linux-upgrade-libsndfile

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;