Multiple buffer overflows in packet_ncp2222.inc in Wireshark (formerly Ethereal) 0.9.7 through 1.0.2 allow attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted NCP packet that causes an invalid pointer to be used.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Centos_linux | — | Upgrade wiresharkUpgrade wireshark-gnome | Dec 1, 2016 | Sep 2, 2008 |
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Sep 2, 2008 |
| Gentoo Linux | — | Upgrade net-analyzer/wireshark. | Oct 30, 2017 | Sep 2, 2008 |
| Oracle_linux | — | Upgrade wiresharkUpgrade wireshark-gnome | Oct 16, 2024 | Sep 2, 2008 |
| Suse | — | Upgrade etherealUpgrade suse-releaseUpgrade ethereal-develUpgrade wireshark-develUpgrade wireshark | Feb 17, 2015 | Sep 2, 2008 |
| Wireshark | — | Upgrade to Wireshark version 1.0.3 | May 3, 2018 | Sep 2, 2008 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub