metasploit

System Requirements and Documentation

MINIMUM HARDWARE

  • 2 GHz+ processor
  • 2 GB RAM available (4 GB recommended)
  • 1 GB available disk space (50 GB recommended)
  • 10/100 Mbps network interface card

OPERATING SYSTEMS

64-bit versions of the following platforms are supported. 

  • Ubuntu Linux 14.04 LTS (RECOMMENDED)
  • Ubuntu Linux 12.04 LTS
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows 8.1
  • Microsoft Windows 7 SP1+
  • Red Hat Enterprise Linux Server 7.1 or later
  • Red Hat Enterprise Linux Server 6.5 or later
  • Red Hat Enterprise Linux Server 5.10 or later
  • Kali Linux 2

BROWSERS

  • Google Chrome (latest)
  • Mozilla Firefox (latest)
  • Microsoft Internet Explorer 11

View more information on Rapid7's end of life policy.

PRODUCT DOCUMENTATION

Installation Guides

Guides

Metasploit Pro
Metasploit Community

Tutorials