Rapid7 VulnDB

Linux DoS Xen 4.2.0 2012-5525

Back to Search

Linux DoS Xen 4.2.0 2012-5525

Created
05/30/2018

Description

This module causes a hypervisor crash in Xen 4.2.0 when invoked from a paravirtualized VM, including from dom0. Successfully tested on Debian 7 3.2.0-4-amd64 with Xen 4.2.0.

Author(s)

  • Christoph Sendner <christoph.sendner@stud-mail.uni-wuerzburg.de>
  • Aleksandar Milenkoski <aleksandar.milenkoski@uni-wuerzburg.de>

Platform

Linux

Architectures

x64

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;