Vulnerability & Exploit Database

Displaying all 2 entries

Results for: CVE-2012-3418 Back to search

SUSE Linux Security Vulnerability: CVE-2012-3418 Vulnerability

  • Severity: 5
  • Published: August 27, 2012

libpcp in Performance Co-Pilot (PCP) before 3.6.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via (1) a PDU with the numcreds field value greater than the number of actual elements to the __pmDecodeCreds function in p_creds.c; (2) the string byte number value to the __pmDecodeNameList function...

DSA-2533-1 pcp -- several vulnerabilities Vulnerability

  • Severity: 5
  • Published: August 27, 2012

The pduread function in pdu.c in libpcp in Performance Co-Pilot (PCP) before 3.6.5 does not properly time out connections, which allows remote attackers to cause a denial of service (pmcd hang) by sending individual bytes of a PDU separately, related to an "event-driven programming flaw."