Vulnerability & Exploit Database

Displaying all 5 entries

Results for: CVE-2017-7895 Back to search

Ubuntu: (Multiple Advisories) (CVE-2017-7895): Linux kernel (HWE) vulnerabilities Vulnerability

  • Severity: 10
  • Published: April 27, 2017

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.

CentOS: (CVE-2017-7895) (Multiple Advisories): kernel Vulnerability

  • Severity: 10
  • Published: April 27, 2017

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.

Oracle Linux: CVE-2017-7895: ELSA-2017-2801 - kernel security update Vulnerability

  • Severity: 10
  • Published: April 27, 2017

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.

Debian: CVE-2017-7895: linux -- security update Vulnerability

  • Severity: 10
  • Published: April 27, 2017

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.