Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2021-23017: Important: nginx:1.16 security update (Multiple Advisories)

Back to Search

Alma Linux: CVE-2021-23017: Important: nginx:1.16 security update (Multiple Advisories)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
06/01/2021
Created
05/05/2022
Added
05/04/2022
Modified
05/13/2022

Description

A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.

Solution(s)

  • alma-upgrade-nginx
  • alma-upgrade-nginx-all-modules
  • alma-upgrade-nginx-filesystem
  • alma-upgrade-nginx-mod-http-image-filter
  • alma-upgrade-nginx-mod-http-perl
  • alma-upgrade-nginx-mod-http-xslt-filter
  • alma-upgrade-nginx-mod-mail
  • alma-upgrade-nginx-mod-stream

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;