Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2022-28734: Important: grub2, mokutil, shim, and shim-unsigned-x64 security update (ALSA-2022-5099)

Back to Search

Alma Linux: CVE-2022-28734: Important: grub2, mokutil, shim, and shim-unsigned-x64 security update (ALSA-2022-5099)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
06/16/2022
Created
08/29/2022
Added
08/24/2022
Modified
09/28/2022

Description

A flaw was found in grub2 when handling split HTTP headers. While processing a split HTTP header, grub2 wrongly advances its control pointer to the internal buffer by one position, which can lead to an out-of-bounds write. This flaw allows an attacker to leverage this issue by crafting a malicious set of HTTP packages making grub2 corrupt its internal memory metadata structure. This leads to data integrity and confidentiality issues or forces grub to crash, resulting in a denial of service attack.

Solution(s)

  • alma-upgrade-grub2-common
  • alma-upgrade-grub2-efi-aa64
  • alma-upgrade-grub2-efi-aa64-cdboot
  • alma-upgrade-grub2-efi-aa64-modules
  • alma-upgrade-grub2-efi-x64
  • alma-upgrade-grub2-efi-x64-cdboot
  • alma-upgrade-grub2-efi-x64-modules
  • alma-upgrade-grub2-pc
  • alma-upgrade-grub2-pc-modules
  • alma-upgrade-grub2-ppc64le
  • alma-upgrade-grub2-ppc64le-modules
  • alma-upgrade-grub2-tools
  • alma-upgrade-grub2-tools-efi
  • alma-upgrade-grub2-tools-extra
  • alma-upgrade-grub2-tools-minimal
  • alma-upgrade-shim-aa64
  • alma-upgrade-shim-unsigned-x64
  • alma-upgrade-shim-x64

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;