Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2024-27282: Moderate: ruby:3.1 security, bug fix, and enhancement update (Multiple Advisories)

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Alma Linux: CVE-2024-27282: Moderate: ruby:3.1 security, bug fix, and enhancement update (Multiple Advisories)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
05/14/2024
Created
06/04/2024
Added
06/03/2024
Modified
07/12/2024

Description

An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

Solution(s)

  • alma-upgrade-ruby
  • alma-upgrade-ruby-bundled-gems
  • alma-upgrade-ruby-default-gems
  • alma-upgrade-ruby-devel
  • alma-upgrade-ruby-doc
  • alma-upgrade-ruby-libs
  • alma-upgrade-rubygem-bigdecimal
  • alma-upgrade-rubygem-bundler
  • alma-upgrade-rubygem-io-console
  • alma-upgrade-rubygem-irb
  • alma-upgrade-rubygem-json
  • alma-upgrade-rubygem-minitest
  • alma-upgrade-rubygem-mysql2
  • alma-upgrade-rubygem-mysql2-doc
  • alma-upgrade-rubygem-pg
  • alma-upgrade-rubygem-pg-doc
  • alma-upgrade-rubygem-power_assert
  • alma-upgrade-rubygem-psych
  • alma-upgrade-rubygem-racc
  • alma-upgrade-rubygem-rake
  • alma-upgrade-rubygem-rbs
  • alma-upgrade-rubygem-rdoc
  • alma-upgrade-rubygem-rexml
  • alma-upgrade-rubygem-rss
  • alma-upgrade-rubygem-test-unit
  • alma-upgrade-rubygem-typeprof
  • alma-upgrade-rubygems
  • alma-upgrade-rubygems-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;