Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2011-2939: Multiple Vulnerabilities in perl <= 5.14.2 may allow remote code execution>

Back to Search

Alpine Linux: CVE-2011-2939: Multiple Vulnerabilities in perl <= 5.14.2 may allow remote code execution

Severity
5
CVSS
(AV:N/AC:H/Au:N/C:P/I:P/A:P)
Published
01/13/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

Off-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service (memory corruption) via a crafted Unicode string, which triggers a heap-based buffer overflow.

Solution(s)

  • alpine-linux-upgrade-perl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;