Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-0053: apache2 < 2.2.22 Various vulnerabilities

Back to Search

Alpine Linux: CVE-2012-0053: apache2 < 2.2.22 Various vulnerabilities

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:N)
Published
10/05/2011
Created
07/25/2018
Added
08/30/2017
Modified
01/02/2018

Description

protocol.c in the Apache HTTP Server 2.2.x through 2.2.21 does not properly restrict header information during construction of Bad Request (aka 400) error documents, which allows remote attackers to obtain the values of HTTPOnly cookies via vectors involving a (1) long or (2) malformed header in conjunction with crafted web script.

Solution(s)

  • alpine-linux-upgrade-apache2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;