Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-3496: Multiple vulnerabilities in Xen 4.x allow remote denial of service

Back to Search

Alpine Linux: CVE-2012-3496: Multiple vulnerabilities in Xen 4.x allow remote denial of service

Severity
5
CVSS
(AV:L/AC:M/Au:N/C:N/I:N/A:C)
Published
11/23/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

XENMEM_populate_physmap in Xen 4.0, 4.1, and 4.2, and Citrix XenServer 6.0.2 and earlier, when translating paging mode is not used, allows local PV OS guest kernels to cause a denial of service (BUG triggered and host crash) via invalid flags such as MEMF_populate_on_demand.

Solution(s)

  • alpine-linux-upgrade-xen

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;