Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-3547: Vulnerability in freeradius < 2.2.0 allow remote code execution

Back to Search

Alpine Linux: CVE-2012-3547: Vulnerability in freeradius < 2.2.0 allow remote code execution

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
09/18/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

Stack-based buffer overflow in the cbtls_verify function in FreeRADIUS 2.1.10 through 2.1.12, when using TLS-based EAP methods, allows remote attackers to cause a denial of service (server crash) and possibly execute arbitrary code via a long "not after" timestamp in a client certificate.

Solution(s)

  • alpine-linux-upgrade-freeradius

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;