Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-5611: Multiple critical vulnerabilities in MySQL < 5.5.28

Back to Search

Alpine Linux: CVE-2012-5611: Multiple critical vulnerabilities in MySQL < 5.5.28

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
10/16/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

Stack-based buffer overflow in the acl_get function in Oracle MySQL 5.5.19 and other versions through 5.5.28, and 5.1.53 and other versions through 5.1.66, and MariaDB 5.5.2.x before 5.5.28a, 5.3.x before 5.3.11, 5.2.x before 5.2.13 and 5.1.x before 5.1.66, allows remote authenticated users to execute arbitrary code via a long argument to the GRANT FILE command.

Solution(s)

  • alpine-linux-upgrade-mysql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;