Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2013-1854: Vulnerability in ruby-activerecord < 2.3.18 allow remote denial of service

Back to Search

Alpine Linux: CVE-2013-1854: Vulnerability in ruby-activerecord < 2.3.18 allow remote denial of service

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
03/19/2013
Created
07/25/2018
Added
08/30/2017
Modified
11/03/2017

Description

The Active Record component in Ruby on Rails 2.3.x before 2.3.18, 3.1.x before 3.1.12, and 3.2.x before 3.2.13 processes certain queries by converting hash keys to symbols, which allows remote attackers to cause a denial of service via crafted input to a where method.

Solution(s)

  • alpine-linux-upgrade-ruby-activerecord

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;