Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2013-1857: Multiple vulnerabilities in ruby-rails < 3.2.13 allow cross-site scripting

Back to Search

Alpine Linux: CVE-2013-1857: Multiple vulnerabilities in ruby-rails < 3.2.13 allow cross-site scripting

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
03/19/2013
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

The sanitize helper in lib/action_controller/vendor/html-scanner/html/sanitizer.rb in the Action Pack component in Ruby on Rails before 2.3.18, 3.0.x and 3.1.x before 3.1.12, and 3.2.x before 3.2.13 does not properly handle encoded : (colon) characters in URLs, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via a crafted scheme name, as demonstrated by including a &#x3a; sequence.

Solution(s)

  • alpine-linux-upgrade-ruby-rails

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;