Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2014-3478: php multiple issues fixed in new 5.5.14

Back to Search

Alpine Linux: CVE-2014-3478: php multiple issues fixed in new 5.5.14

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
07/09/2014
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

Buffer overflow in the mconvert function in softmagic.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (application crash) via a crafted Pascal string in a FILE_PSTRING conversion.

Solution(s)

  • alpine-linux-upgrade-php

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;