Integer overflow in the ape_decode_frame function in libavcodec/apedec.c in FFmpeg 2.4 through 3.3.2 allows remote attackers to cause a denial of service (out-of-array access and application crash) or possibly have unspecified other impact via a crafted APE file.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Alpine Linux | — | Upgrade ffmpeg | Oct 1, 2024 | Jul 17, 2017 |
| Debian | — | Upgrade ffmpeg | Dec 5, 2017 | Jul 17, 2017 |
| Ffmpeg | — | Upgrade to FFmpeg version 3.2.7Upgrade to FFmpeg version 3.3.3Upgrade to FFmpeg version 3.0.9Upgrade to FFmpeg version 2.8.13Upgrade to FFmpeg version 3.1.10Upgrade to FFmpeg version 2.4.14 | Sep 29, 2017 | Jul 17, 2017 |
| Suse | — | Upgrade libavutil55Upgrade libavutil-develUpgrade libavresample-develUpgrade libswresample2Upgrade libswscale4Upgrade libswresample-develUpgrade libavcodec-develUpgrade libavformat-develUpgrade libpostproc54Upgrade libpostproc-develUpgrade libavfilter6Upgrade libavformat57Upgrade libavdevice57Upgrade libswscale-develUpgrade libavresample3Upgrade libavcodec57Upgrade ffmpeg | Sep 16, 2017 | Jul 17, 2017 |
| Ubuntu | — | Upgrade ffmpeg | Nov 19, 2024 | Jul 17, 2017 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub