Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2017-5884: gtk-vnc two input validation flaws

Back to Search

Alpine Linux: CVE-2017-5884: gtk-vnc two input validation flaws

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
02/28/2017
Created
07/25/2018
Added
08/30/2017
Modified
12/27/2019

Description

gtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) hextile, or (3) copyrect tile.

Solution(s)

  • alpine-linux-upgrade-gtk-vnc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;