Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for gnutls (ALAS-2014-301) (CVE-2014-0092)

Back to Search

Amazon Linux AMI: Security patch for gnutls (ALAS-2014-301) (CVE-2014-0092)

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:N)
Published
03/06/2014
Created
07/25/2018
Added
04/08/2014
Modified
07/04/2017

Description

lib/x509/verify.c in GnuTLS before 3.1.22 and 3.2.x before 3.2.12 does not properly handle unspecified errors when verifying X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.

Solution(s)

  • amazon-linux-upgrade-gnutls
  • amazon-linux-upgrade-gnutls-debuginfo
  • amazon-linux-upgrade-gnutls-devel
  • amazon-linux-upgrade-gnutls-guile
  • amazon-linux-upgrade-gnutls-utils

References

  • amazon-linux-upgrade-gnutls
  • amazon-linux-upgrade-gnutls-debuginfo
  • amazon-linux-upgrade-gnutls-devel
  • amazon-linux-upgrade-gnutls-guile
  • amazon-linux-upgrade-gnutls-utils

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;