The snoop_read function in wiretap/snoop.c in Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 does not properly handle certain virtualizable buffers, which allows remote attackers to cause a denial of service (application crash) via a large length value in a snoop file that triggers a stack-based buffer over-read.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Centos_linux | — | Upgrade wireshark-develUpgrade wiresharkUpgrade wireshark-gnome | Dec 1, 2016 | Jun 6, 2011 |
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Jun 6, 2011 |
| Gentoo Linux | — | Upgrade net-analyzer/wireshark. | Oct 30, 2017 | Jun 6, 2011 |
| Oracle_linux | — | Upgrade wireshark-gnomeUpgrade wiresharkUpgrade wireshark-devel | Oct 16, 2024 | Jun 6, 2011 |
| Redhat_linux | — | No solution exists | Jul 9, 2025 | May 31, 2011 |
| Suse | — | Upgrade libwscodecs1Upgrade libwiretap15Upgrade libwireshark19Upgrade libwireshark18Upgrade libwsutil17Upgrade wiresharkUpgrade wireshark-develUpgrade libwireshark9Upgrade libwiretap6Upgrade wireshark-ui-qtUpgrade wireshark-gtkUpgrade libwsutil16Upgrade libwireshark8Upgrade libwsutil7Upgrade libwiretap7Upgrade libwiretap16Upgrade libwsutil8 | Dec 12, 2013 | Jun 28, 2013 |
| Ubuntu | — | Upgrade wireshark | Nov 19, 2024 | Jun 6, 2011 |
| Wireshark | — | Upgrade to Wireshark version 1.4.7Upgrade to Wireshark version 1.2.17 | Oct 4, 2017 | Jun 6, 2011 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub