Stack-based buffer overflow in the GD extension in PHP before 5.2.15 and 5.3.x before 5.3.4 allows context-dependent attackers to cause a denial of service (application crash) via a large number of anti-aliasing steps in an argument to the imagepstext function.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | Jan 18, 2011 |
| Php | — | Upgrade to PHP version 5.3.4Upgrade to PHP version 5.2.15 | Oct 1, 2012 | Jan 18, 2011 |
| Suse | — | Upgrade php5-gdUpgrade php5-dbaseUpgrade php5-xmlwriterUpgrade apache2-mod_php5Upgrade php5-pspellUpgrade php5-wddxUpgrade php5Upgrade php5-pcntlUpgrade php5-zlibUpgrade php5-calendarUpgrade php5-mysqlUpgrade php5-pgsqlUpgrade php5-zipUpgrade php5-bcmathUpgrade php5-tokenizerUpgrade php5-fastcgiUpgrade php5-gettextUpgrade php5-suhosinUpgrade php5-hashUpgrade php5-sysvshmUpgrade php5-exifUpgrade php5-xmlreaderUpgrade php5-gmpUpgrade php5-xslUpgrade php5-sysvsemUpgrade php5-iconvUpgrade php5-ctypeUpgrade php5-jsonUpgrade php5-bz2Upgrade php5-shmopUpgrade php5-mcryptUpgrade php5-odbcUpgrade php5-dbaUpgrade php5-domUpgrade php5-soapUpgrade php5-mbstringUpgrade php5-ldapUpgrade php5-opensslUpgrade php5-pearUpgrade php5-pdoUpgrade php5-xmlrpcUpgrade php5-ftpUpgrade php5-sysvmsgUpgrade php5-snmpUpgrade php5-curl | Feb 17, 2015 | Jun 28, 2013 |
| Ubuntu | — | Upgrade php-pearUpgrade php5-intlUpgrade php5Upgrade php5-devUpgrade php5-commonUpgrade php5-cgiUpgrade php5-gdUpgrade php5-curlUpgrade libapache2-mod-php5Upgrade php5-cli | Nov 8, 2024 | Jan 18, 2011 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub