Off-by-one error in the is_rtsp_request_or_reply function in epan/dissectors/packet-rtsp.c in the RTSP dissector in Wireshark 1.10.x before 1.10.10 and 1.12.x before 1.12.1 allows remote attackers to cause a denial of service (application crash) via a crafted packet that triggers parsing of a token located one position beyond the current position.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Centos_linux | — | Upgrade wireshark-gnomeUpgrade wiresharkUpgrade wireshark-devel | Dec 1, 2016 | Sep 20, 2014 |
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Sep 20, 2014 |
| Gentoo Linux | — | Upgrade net-analyzer/wireshark. | Oct 30, 2017 | Sep 20, 2014 |
| Oracle Solaris | — | Upgrade diagnostic/wireshark/wireshark-common to version 1.10.10-0.175.2.4.0.3.0 on Solaris 11.2Upgrade diagnostic/wireshark/tshark to version 1.10.10-0.175.2.4.0.3.0 on Solaris 11.2Upgrade diagnostic/wireshark to version 1.10.10-0.175.2.4.0.3.0 on Solaris 11.2 | May 29, 2017 | Sep 20, 2014 |
| Oracle_linux | — | Upgrade wiresharkUpgrade wireshark-gnomeUpgrade wireshark-devel | Oct 16, 2024 | Sep 20, 2014 |
| Suse | — | Upgrade libwiretap7Upgrade libwsutil8Upgrade wireshark-develUpgrade wiresharkUpgrade libwireshark9Upgrade libwscodecs1Upgrade wireshark-ui-qt | Dec 18, 2015 | Sep 20, 2014 |
| Ubuntu | — | Upgrade wireshark | Nov 19, 2024 | Sep 20, 2014 |
| Wireshark | — | Upgrade to Wireshark version 1.12.1Upgrade to Wireshark version 1.10.10 | Oct 4, 2017 | Sep 20, 2014 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub