In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Struts | — | Upgrade to Apache Struts version 2.3.34Upgrade to Apache Struts version 2.5.13 | Sep 20, 2017 | Sep 20, 2017 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub