The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Advanced Product Fields For Woocommerce Plugin | — | Update advanced-product-fields-for-woocommerce plugin to version 1.6.22, or a newer patched version | Oct 30, 2026 | Aug 21, 2026 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub