Several Newfold plugins are vulnerable to Authentication Bypass. The vulnerability exists because the plugins bundle the wp-module-data module. In the module, the `authenticate()` method — registered on the `rest_authentication_errors` filter and therefore evaluated for every unauthenticated REST API request — performs an HMAC-style Bearer token comparison that degenerates when `HiiveConnection::get_auth_token()` returns `false`: PHP coerces `strrev(false)` to `strrev('')`, collapsing the secret salt to the publicly known constant `hash('sha256', '') = e3b0c44...`, while all remaining hash inputs (HTTP method, request URL, raw request body, and the `X-Timestamp` header) remain fully attacker-controlled. This makes it possible for unauthenticated attackers to compute a valid Bearer token entirely offline, pass the token equality check, and have `wp_set_current_user()` invoked against the first administrator returned by `get_users(['role' => 'administrator'])`, granting full administrator-level access and enabling arbitrary REST API operations such as creating new administrator accounts and achieving complete site takeover. Vulnerable versions are WP Plugin Crazy Domains (<= 2.5.2), WP Plugin Web (<= 2.3.4), WP Plugin Hostgator (<= 3.1.0), WP Plugin Bluehost (<= 4.17.1). The affected module is vulnerable in versions up to, and including, 2.9.4.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Bluehost Wordpress Plugin Plugin | — | Update bluehost-wordpress-plugin plugin to version 4.19.1, or a newer patched version | Oct 30, 2026 | Sep 8, 2026 |
| Wp Module Data Plugin | — | Update wp-module-data plugin to version 2.9.8, or a newer patched version | Oct 30, 2026 | Sep 8, 2026 |
| Wp Plugin Crazy Domains Plugin | — | Update wp-plugin-crazy-domains plugin to version 2.5.3, or a newer patched version | Oct 30, 2026 | Sep 8, 2026 |
| Wp Plugin Hostgator Plugin | — | Update wp-plugin-hostgator plugin to version 3.2.1, or a newer patched version | Oct 30, 2026 | Sep 8, 2026 |
| Wp Plugin Web Plugin | — | Update wp-plugin-web plugin to version 2.3.6, or a newer patched version | Oct 30, 2026 | Sep 8, 2026 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub