Rapid7 Vulnerability & Exploit Database

F5 Networks: K15605 (CVE-2014-6032): XML Entity Injection vulnerabilities CVE-2014-6032 and CVE-2014-6033

Back to Search

F5 Networks: K15605 (CVE-2014-6032): XML Entity Injection vulnerabilities CVE-2014-6032 and CVE-2014-6033

Severity
6
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:P)
Published
09/17/2014
Created
07/25/2018
Added
02/16/2017
Modified
10/13/2017

Description

Multiple XML External Entity (XXE) vulnerabilities in the Configuration utility in F5 BIG-IP LTM, ASM, GTM, and Link Controller 11.0 through 11.6.0 and 10.0.0 through 10.2.4, AAM 11.4.0 through 11.6.0, ARM 11.3.0 through 11.6.0, Analytics 11.0.0 through 11.6.0, APM and Edge Gateway 11.0.0 through 11.6.0 and 10.1.0 through 10.2.4, PEM 11.3.0 through 11.6.0, PSM 11.0.0 through 11.4.1 and 10.0.0 through 10.2.4, and WOM 11.0.0 through 11.3.0 and 10.0.0 through 10.2.4 and Enterprise Manager 3.0.0 through 3.1.1 and 2.1.0 through 2.3.0 allow remote authenticated users to read arbitrary files and cause a denial of service via a crafted request, as demonstrated using (1) viewList or (2) deal elements.

Solution(s)

  • f5-big-ip-upgrade-latest

References

  • f5-big-ip-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;