Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2005-2491: libpcre: Heap integer overflow

Back to Search

Gentoo Linux: CVE-2005-2491: libpcre: Heap integer overflow

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
08/23/2005
Created
07/25/2018
Added
10/30/2017
Modified
10/29/2021

Description

Integer overflow in pcre_compile.c in Perl Compatible Regular Expressions (PCRE) before 6.2, as used in multiple products such as Python, Ethereal, and PHP, allows attackers to execute arbitrary code via quantifier values in regular expressions, which leads to a heap-based buffer overflow.

Solution(s)

  • gentoo-linux-upgrade-app-office-gnumeric
  • gentoo-linux-upgrade-dev-lang-python
  • gentoo-linux-upgrade-dev-libs-libpcre
  • gentoo-linux-upgrade-dev-php-mod_php
  • gentoo-linux-upgrade-dev-php-php
  • gentoo-linux-upgrade-dev-php-php-cgi
  • gentoo-linux-upgrade-net-www-mod_ssl
  • gentoo-linux-upgrade-www-servers-apache

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;