Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2009-4035: Xpdf: User-assisted execution of arbitrary code

Back to Search

Gentoo Linux: CVE-2009-4035: Xpdf: User-assisted execution of arbitrary code

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
12/21/2009
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The FoFiType1::parse function in fofi/FoFiType1.cc in Xpdf 3.0.0, gpdf 2.8.2, kpdf in kdegraphics 3.3.1, and possibly other libraries and versions, does not check the return value of the getNextLine function, which allows context-dependent attackers to execute arbitrary code via a PDF file with a crafted Type 1 font that can produce a negative value, leading to a signed-to-unsigned integer conversion error and a buffer overflow.

Solution(s)

  • gentoo-linux-upgrade-app-text-xpdf

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;