Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2011-2764: Urban Terror: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2011-2764: Urban Terror: Multiple vulnerabilities

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
08/03/2011
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The FS_CheckFilenameIsNotExecutable function in qcommon/files.c in the ioQuake3 engine 1.36 and earlier, as used in World of Padman, Smokin' Guns, OpenArena, Tremulous, and ioUrbanTerror, does not properly determine dangerous file extensions, which allows remote attackers to execute arbitrary code via a crafted third-party addon that creates a Trojan horse DLL file.

Solution(s)

  • gentoo-linux-upgrade-games-fps-urbanterror

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;