Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2013-2061: OpenVPN: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2013-2061: OpenVPN: Multiple vulnerabilities

Severity
3
CVSS
(AV:N/AC:H/Au:N/C:P/I:N/A:N)
Published
11/17/2013
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The openvpn_decrypt function in crypto.c in OpenVPN 2.3.0 and earlier, when running in UDP mode, allows remote attackers to obtain sensitive information via a timing attack involving an HMAC comparison function that does not run in constant time and a padding oracle attack on the CBC mode cipher.

Solution(s)

  • gentoo-linux-upgrade-net-misc-openvpn

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;