Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2014-1895: Xen: Multiple Vunlerabilities

Back to Search

Gentoo Linux: CVE-2014-1895: Xen: Multiple Vunlerabilities

Severity
6
CVSS
(AV:A/AC:M/Au:S/C:P/I:N/A:C)
Published
04/01/2014
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Off-by-one error in the flask_security_avc_cachestats function in xsm/flask/flask_op.c in Xen 4.2.x and 4.3.x, when the maximum number of physical CPUs are in use, allows local users to cause a denial of service (host crash) or obtain sensitive information from hypervisor memory by leveraging a FLASK_AVC_CACHESTAT hypercall, which triggers a buffer over-read.

Solution(s)

  • gentoo-linux-upgrade-app-emulations-xen
  • gentoo-linux-upgrade-app-emulations-xen-pvgrub
  • gentoo-linux-upgrade-app-emulations-xen-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;