Rapid7 Vulnerability & Exploit Database

CESA-2002:138: unzip security update

Back to Search

CESA-2002:138: unzip security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
10/28/2002
Created
07/25/2018
Added
03/12/2010
Modified
07/04/2017

Description

The unzip and tar utilities contain vulnerabilities which can allow arbitrary files to be overwritten during archive extraction.

The unzip and tar utilities are used for dealing with archives, which are multiple files stored inside of a single file. A directory traversal vulnerability in unzip version 5.42 and earlier, as well as GNU tar 1.13.19 and earlier, allows attackers to overwrite arbitrary files during archive extraction via a ".." (dot dot) in an extracted filename (CAN-2001-1267, CAN-2001-1268). In addition, unzip version 5.42 and earlier also allows attackers to overwrite arbitrary files during archive extraction via filenames in the archive that begin with the "/" (slash) character (CAN-2001-1269). During testing of the fix to GNU tar, we discovered that GNU tar 1.13.25 was still vulnerable to a modified version of the same problem. CentOS has provided a patch to tar 1.3.25 to correct this problem (CAN-2002-0399). Users of unzip and tar are advised to upgrade to these errata packages, containing unzip version 5.50 and a patched version of GNU tar 1.13.25, which are not vulnerable to these issues.

Solution(s)

  • centos-upgrade-tar
  • centos-upgrade-unzip

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;