Rapid7 Vulnerability & Exploit Database

RHSA-2002:043: Updated openssh packages available

Back to Search

RHSA-2002:043: Updated openssh packages available

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
03/15/2002
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated openssh packages are now available for Red Hat Linux 7, 7.1, and 7.2 which close a remotely-exploitable vulnerability in sshd.

Joost Pol has discovered an off-by-one error in all versions of the OpenSSH daemon (sshd) prior to version 3.1. This issue could allow an authenticated user to cause sshd to corrupt its heap, potentially allowing arbitrary code to be executed on the remote server. Alternatively, a malicious SSH server could be crafted to attack a vulnerable OpenSSH client. Users are advised to upgrade to these errata packages containing OpenSSH 3.1, which is not vulnerable to this issue. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-0083 to this issue.

Solution(s)

  • redhat-upgrade-openssh
  • redhat-upgrade-openssh-askpass
  • redhat-upgrade-openssh-askpass-gnome
  • redhat-upgrade-openssh-clients
  • redhat-upgrade-openssh-server

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;