Updated openssh packages are now available for Red Hat Linux 7, 7.1, and 7.2 which close a remotely-exploitable vulnerability in sshd.
Joost Pol has discovered an off-by-one error in all versions of the OpenSSH daemon (sshd) prior to version 3.1. This issue could allow an authenticated user to cause sshd to corrupt its heap, potentially allowing arbitrary code to be executed on the remote server. Alternatively, a malicious SSH server could be crafted to attack a vulnerable OpenSSH client. Users are advised to upgrade to these errata packages containing OpenSSH 3.1, which is not vulnerable to this issue. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-0083 to this issue.